Back to connectors… Back to Sage 300...

4.11 IC Item creation - Unit of Measure. Record Already Exists... (3 replies and 1 comment)

Sue Herrmannn
3 months ago
Sue Herrmannn 3 months ago

I am trying to create IC Items in Sage 300. There are 3 levels in the connector: item, unit of measure, taxes. On the item mapping, it requires the Stocking Unit of Measure - which I set to EA. Under the unit of measure, you can only map the uom and conversion - which I set to EA and 1. But when I try to create the item, I get an error message that says ACCPAC API Error 1023 - Unit of Measure. Record Already Exists.

I have tried unmapping the Stocking unit of measure, I've tried unmapping the unit and conversion. I've gone in and created an EA unit of measure under IC Setup, UOMs.... Nothing seems to work.

Also, while I LOVE the new look of the preview screen. When I get this error, it removes all data from the preview - so if there was a warning or error at some level I can't see it because the data has all been blanked out. It makes it difficult to determine what's happening on the preview of the Sage 300 connector.

I've attached 2 screenshots - one while the preview is refreshing - showing my data. One with the error message and no preview data showing.

https://www.realisable.co.uk/wp-content/uploads/2019/06/Iman-Sage-300-Connector-while-preview-is-refreshing-shows-data.jpg
https://www.realisable.co.uk/wp-content/uploads/2019/06/Iman-Sage-300-connector-with-error-no-preview-data.jpg
Sue Herrmannn
3 months ago
Sue Herrmannn 3 months ago

Note: I am attempting to create items in Sage 300 5.6! Sorry - I should have mentioned that...

Support
3 months ago
Support 3 months ago

Sue, in reply....

  1. UOM - You have mapped the Stocking Unit of Measure field, which will add the default UoM to the Item. If you've separately set the UoMs on the child transaction type, this may cause a duplicate.
  2. Preview & Errors - Yes, we've go this slated to be improved a product update.

Thanks

Sue Herrmannn
3 months ago

Wow - I figured it out. thanks! I had tried unmapping either the Stocking uom on the Items or unmapping the child Units of measure fields. But either way, it threw an error. But then I completely disconnected my child units record from the Units of Measure screen - rather than just unmapping the fields and that worked. (All this time in Iman, and it's still teaching me new tricks...) Thanks!

Sue Herrmannn
3 months ago
Sue Herrmannn 3 months ago

 (closed...)

Contact

Realisable Software Ltd provides code-free, cost-effective applications integration solutions for SMEs. Our core IMan product is designed to integrate almost any application with a number of Sage solutions and online payment processors.

Looking to purchase IMan, please see our resellers here.

Realisable Software
Ph: +44 (0) 208 123 1017

Copyright © Realisable. All rights reserved.
Realisable is a registered trademark

Close

Request Demo

Realisable Software Ltd provides code-free, cost-effective applications integration solutions for SMEs. Our core IMan product is designed to integrate almost any application with a number of Sage solutions and online payment processors.

Looking to purchase IMan, please see our resellers here.

Realisable Software
Ph: +44 (0) 208 123 1017

Copyright © Realisable. All rights reserved.
Realisable is a registered trademark

Close

Access Downloads

Realisable Software Ltd provides code-free, cost-effective applications integration solutions for SMEs. Our core IMan product is designed to integrate almost any application with a number of Sage solutions and online payment processors.

Looking to purchase IMan, please see our resellers here.

Realisable Software
Ph: +44 (0) 208 123 1017

Copyright © Realisable. All rights reserved.
Realisable is a registered trademark

Close